Subject: Re: [boost] [type_erasure] Review started (July 18-27, 2012)
From: Eric Niebler (eric_at_[hidden])
Date: 2012-07-29 18:36:04
On 7/29/2012 3:29 PM, Eric Niebler wrote:
> I strongly encourage you to
> consider the name Boost.ValueInterface or something more descriptive of
> the anticipated *usage* of your library, rather than how it's implemented.
Hit send too soon, sorry. Your library can also be thought of as adding
structural typing or duck typing to C++, so:
would all be fine, descriptive names for the library, IMO.
-- Eric Niebler BoostPro Computing http://www.boostpro.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk