Boost logo

Boost :

Subject: Re: [boost] [type_erasure] Review started (July 18-27, 2012)
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2012-08-09 05:27:46


> -----Original Message-----
> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of Paul A.
> Bristow
> Sent: Wednesday, August 08, 2012 5:40 PM
> To: boost_at_[hidden]
> Subject: Re: [boost] [type_erasure] Review started (July 18-27, 2012)

I've checked that using an

    typedef any<
        mpl::vector
        < // List of concepts.
            typeid_<>,
            arithmetic<>, // Re-using another list of concepts.
            negatable<>,
            ostreamable<>
>
> arith_type;

    arith_type x(10);
    arith_type y(4);

but find that while

x = -y; works as expected,

x = +y doesn't work.

Of course the + is redundant, but I have used it for clarity.

Should the unary plus be included for completeness?

Paul

---
Paul A. Bristow,
Prizet Farmhouse, Kendal LA8 8AB  UK
+44 1539 561830  07714330204
pbristow_at_[hidden]

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk