Boost logo

Boost :

Subject: Re: [boost] [preprocessor] Variadics suggestion
From: Lorenzo Caminiti (lorcaminiti_at_[hidden])
Date: 2012-10-08 12:25:18

On Mon, Oct 8, 2012 at 9:00 AM, Paul Mensonides <pmenso57_at_[hidden]> wrote:
> On Sun, 07 Oct 2012 15:49:40 -0400, Edward Diener wrote:
>>> 2) For a macro library, do we still need to have a BOOST_ prefix or
>>> could I just keep the CHAOS_PP_ prefix? I cannot use BOOST_PP_ without
>>> bending over backwards to find contrived names for everything, and the
>>> namespace of brief names beginning with BOOST_ is tiny--especially when
>>> a library provides hundreds of user-interface (i.e. not implementation
>>> detail macros).
>> BOOST_CHAOS_PP_... seems normal to me.
> It seems *way* to long to me.

I don't think so, it's not long. However, "chaos" doesn't mean
anything so I'd prefer a more descriptive name... maybe for pp




Note these opinions are all very subjective...


Boost list run by bdawes at, gregod at, cpdaniel at, john at