Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Gennadiy Rozenal (rogeeff_at_[hidden])
Date: 2012-10-20 15:42:20
Steven Watanabe <watanabesj <at> gmail.com> writes:
> > I. New testing tool BOOST_CHECKA
> > This tool is based on excellent idea from Kevlin Henney. I chose the name
> > CHECKA for this tool due to the lack of better name, but I am open to
> > suggestions.
> BOOST_CHECK_EXPR? Ideally I'd like this
> to be called BOOST_CHECK, but I don't
> think that can be made perfectly backwards
Yep. There are few cases where BOOST_CHECKA can't handle what BOOST_CHECK can. I
really would prefer name as short as possible. This is intended to be a primary
testing tool from now on. And I am kind of stuck with triplets of
WARN/CHECK/REQUIRE, so any name has to fit into this schema. I've considered:
BOOST_UCHECK (U for universal)
BOOST_CHECK_EX (EX for extended)
BOOST_CHECK_ASSERTION too long?
BOOST_CASSERT/BOOST_WASSERT/BOOST_RASSERT (W/C/R for warn check and require
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk