Boost logo

Boost :

Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Alexander Lamaison (awl03_at_[hidden])
Date: 2012-10-21 06:56:20

"Vicente J. Botet Escriba" <vicente.botet_at_[hidden]> writes:

> Le 20/10/12 05:03, Gennadiy Rozenal a écrit :
>> Hi,
>> It's been a long while since I merged any changes into boost release and by
>> now there are whole bunch of new features there. Some are small, but some
>> others are big ones such that they can change the way people use the library.
>> I'd like to list them here (excluding bug fixes and removal of deprecated
>> interfaces) and ask what should we do with these. Specifically let me know
>> if you think these require some kind of (mini) review from community, but any
>> other comments are welcome as well.
> Hi,
> thanks for taking the time to make this ready for release.
> I would appreciate if all the new Boost.Test macros start by
> BOOST_TEST_ and you provide the equivalent macros for existing ones
> that don't follows this pattern.
> I understand that you want short names, but avoid possible collisions
> is better than having short names. I could accept also BOOST_TF_ as
> Boost Test Framework or BOOST_TL_ as Boost Test Library.
>> So here we go:
>> I. New testing tool BOOST_CHECKA
>> This tool is based on excellent idea from Kevlin Henney. I chose the name
>> CHECKA for this tool due to the lack of better name, but I am open to
>> suggestions. This testing tool capable of replacing whole bunch of existing
>> other tools like BOOST_CHECK_EQUAL, BOOST_CHECK_GT etc. Usage is the most
>> natural you can wish for:
>> BOOST_CHECKA( var1 - var2 >= 12 );
>> And the output will include as much information as we can get:
>> error: in "foo": check var1 - var2 >= 12 failed [23-15<12]
> I like this a lot. How it works?
> What about BOOST_TEST_CHECK (see above)?

Or just BOOST_TEST as that is now the default testing tool? TEST_CHECK
an TEST_ASSERTION etc. are redundant as it says the same thing twice.


Boost list run by bdawes at, gregod at, cpdaniel at, john at