Subject: Re: [boost] Boost.Process 0.5: Another update/potential candidate for an official library
From: Boris Schaeling (boris_at_[hidden])
Date: 2012-11-13 19:00:15
On Tue, 13 Nov 2012 23:15:02 +0100, Francois Duranleau
> [...]If we look at the variant using a vector for arguments, in that
> seems like it is quite trivial to get the executable as the first
> element in the vector. Anyways, seems to me that either you have to
> merge args in a vector in a single string on Windows, or split the
> string into an array of args on Unix. So if you anyway have to split,
> why not make run_exe optional? Or are you using the shell on Unix?
> Hopefully not (sorry, I did not download and look at the code, just
> the documentation a bit).
You are right, the command line is indeed already split.
> [...]no need for set_cmd_line and set_args to be different. In this case,
> args could be overloaded for a string (and/or c string) and a sequence
> (templated), or even a range or pair of iterators. args could be named
> something else, my point is, the command line being specified as a
> string or a sequence of tokens serves the same final purpose, hence it
> seems to me there is no need for a different name. Granted, this
Yep, sounds all reasonable to me. That's definitely something which should
be put back on the todo-list.
Thanks for your feedback, too!
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk