Boost logo

Boost :

Subject: Re: [boost] [variant] Please vote for behavior (Was: Basic rvalue and C++11 features seupport)
From: Robert Ramey (ramey_at_[hidden])
Date: 2013-01-21 13:12:37

Antony Polukhin wrote:
> Current implementation of recursive_wrapper move constructor is not
> optimal:
> recursive_wrapper<T>::recursive_wrapper(recursive_wrapper&& operand)
> : p_(new T(std::move(operand.get()) ))
> { }
> During descussion were made following proposals:


> Please, vote for solution or propose a better one.

A very good post and interesting discussion. But one small sticking point
in my
opinion. I would prefer that the word "vote" be replaced with "make

The word "vote" suggests that all input will be weighted equally. Our
reviewing process recognises that all input is not equal and assigns to one
person - review manager - the role of weighing all the input. In some cases
the review manager may (and I assume has) over-ruled the majority because
the arguments of the minority were better in his view. So I would have
preferred that the the post used the phrase

"Please submit recommendation on design"

rather than

"Please vote for behavior"

Robert Ramey

Boost list run by bdawes at, gregod at, cpdaniel at, john at