Boost logo

Boost :

Subject: Re: [boost] Serialise on Mac OSX 10.8, XCode and GCC
From: Andrew Hundt (athundt_at_[hidden])
Date: 2013-03-22 14:08:01

I've run into this problem and it is a bit of a pain. I initially installed
boost via MacPorts which I have found the easiest way to keep things
working and up to date.

I'm using Xcode 4.6.1.

I use CMake to generate my xcodeproj, but hopefully some of this should
still apply.

Then, to resolve some of these other issues with targets but I believe I
needed to change some of the build settings on the xcodeproj. If you go to
the little folder icon aka Project Navigator > Project Build settings (on
the right) > Architectures + Base SDK + Supported Platforms + Valid
Architecture. I have found that messing with some of those settings gets
things to work again.

The other thing I may have done is regenerated my Xcode project in CMake
because the generated targets were out of date, though that may or may not
be helpful to you.

I'm sorry I don't have a more straightforward answer, but I never actually
wrote the steps down and I figure that some suggestions are better than
none and may lead you in the right direction.

Andrew Hundt

On Fri, Mar 22, 2013 at 1:27 PM, Tim Burgess <tim_at_[hidden]> wrote:

> Hi,
> I have an XCode c++ project that uses the static serialisation library (as
> well as FileSystem, IOStream and System). The project started out on XCode
> 3.6 on Mac OSX 10.6, where it successfully built and ran using Boost
> 1_49_0,
> built against Apple's 10.6 SDK.
> However, I needed to use the XCode debugger to track down some run-time
> issues and found I couldn't access the debugger on this version of XCode
> (I'm blind and have to use the VoiceOver utility to gain access to my Mac).
> Having taken advice, I upgraded to Mac OSX 10.8, SDK 10.8 and XCode 4.6,
> which solves my debugging issue.
> Unfortunately, my project no longer links correctly. The linker complains
> that it can't find symbols for my architecture (x86_64) - the messages are
> in the the form:
> "boost::archive::basic_xml_iarchive<boost::archive::xml_wiarchive>::load_sta
> rt(char const*)", referenced from:
> "boost::archive::basic_xml_iarchive<boost::archive::xml_wiarchive>::load_ove
> rride(boost::archive::version_type&, int)", referenced from:
> "boost::archive::basic_xml_iarchive<boost::archive::xml_wiarchive>::load_ove
> rride(boost::archive::class_id_type&, int)", referenced from:
> (I've truncated the output here for brevity). I get no linker errors for
> any of the other Boost binaries - it's only the serialisation library that
> creates a problem.
> The project is configured to compile with the llvmgcc42 compiler, as it
> also
> uses the wxWidgets libraries, which don't support compilation using clang.
> Boost versions tried:
> 1_50_0, 1_52_0 and 1_53_0.
> Boost build options tried:
> 1 - Default (no options specified) - this worked on Mac OSX 10.6, Snow
> Leopard.
> 2 - As follows:
> macosx-version=10.3 macosx-version-min=10.6 architecture=combined
> threading=multi link=static address-model=32_64
> 3 - As follows:
> architecture=combined address-model=32_64
> I'm a novice using Boost and the Mac, so would appreciate any suggestions
> as
> to how I can resolve this issue.
> Best wishes.
> Tim Burgess
> Raised Bar Ltd.
> Tel: +44 (0)1827 719822
> Web:
> We can supply Roland and Avid products with specialist pre and post-sales
> support for visually-impaired users - just drop us a line for a quote.
> Don't forget to sign our on-line petition to lobby for improved access to
> music education and music technology at:
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at