Boost logo

Boost :

Subject: Re: [boost] [thread] countdown_latch
From: Rob Stewart (robertstewart_at_[hidden])
Date: 2013-05-14 17:37:32

On May 14, 2013, at 1:21 PM, Gaetano Mendola <mendola_at_[hidden]> wrote:

> On 14/05/2013 13.09, Rob Stewart wrote:
>> Thank you for that. I don't like the "count down" part of the name, at least of the release operation, and while "await" is fine, it isn't helpful to use a new verb. Why not parallel barrier and condition_variable, and use "wait" and "notify"?
> Given it has a clearly inspiration on Java one I would leave it like it it now with the excpetion to permit count_down even if the counter is zero already.

If the component is useful, the language in which it originates should have some influence on naming for the rest, but if the names are awkward, or don't fit well in the new language, changes are warranted. (There are enough inconsistencies on the standard library; we don't need more just to match expectations of those using another language.) I especially don't think C++ should be modeled on Java.


(Sent from my portable computation engine)

Boost list run by bdawes at, gregod at, cpdaniel at, john at