Subject: Re: [boost] [shared_array] Why not in C++11 ?
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2013-07-08 02:42:18
On Mon, Jul 8, 2013 at 10:26 AM, Glen Fernandes
> Sid Sacek wrote:
> You mentioned in an earlier mail that you would prefer that size()
> return a value like -1 in such a case. That also feels very strange to
> me; i.e. returning a size_t but reserving a value like -1 to indicate
> unknown size.
+1, I hate magic values.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk