Boost logo

Boost :

Subject: Re: [boost] [build] is still broken
From: Eric Niebler (eniebler_at_[hidden])
Date: 2013-10-28 17:22:11

On 10/28/2013 1:24 PM, niXman wrote:
> Stephan T. Lavavej 2013-10-28 21:39:
>> It would be nice if niXman could sync to before checkin 86460 in order
>> to exonerate it.
> The same error.


> D:\boost-trunk>bootstrap.bat mingw

Forgive the stupid question, but shouldn't you be using
from the MSYS prompt instead of bootstrap.bat from the DOS prompt?

Anyway, I installed MinGW following Stephan's instructions, and found
that still doesn't work on trunk, but due to this:

> ###
> ### Using 'mingw' toolset.
> ###
> rm -rf bootstrap
> mkdir bootstrap
> gcc -DNT -o bootstrap/jam0 command.c compile.c constants.c debug.c execcmd.c frames.c function.c glob.c hash.c hdrmacro.c headech.c subst.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c class.c cwd.c native.c md5.c w32_getreg.c modules/builtins.c: In function 'builtin_readlink':
> builtins.c:1879:39: error: 'FSCTL_GET_REPARSE_POINT' undeclared (first use in this function)
> builtins.c:1879:39: note: each undeclared identifier is reported only once for each function it appears in

So it looks like something is still broken. Stephan?

Eric Niebler

Boost list run by bdawes at, gregod at, cpdaniel at, john at