Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-05 13:36:54

>> So bit counts have to use a different naming convention to avoid
>> confusion.
>> How about:
>> cpp_bin_float_single;
>> cpp_bin_float_double;
>> cpp_bin_float_quad;
> I'm not sure what these actually provide.

We're trying to find "good" names for the software emulations of the IEEE
single/double and quad precision (32, 64 and 128 bit) types.

> Is cpp_bin_float_double the same as the current
> boost::multiprecision::float53_t

We don't have anything currently.

> and *emulates* std::float64_t which is true IEEE layout 64-bit double?


> whereas float_53_t has 53 significand but a much bigger exponent)?

No the same exponent range, and the same behavior in all aspects except size
and bit-layout.


Boost list run by bdawes at, gregod at, cpdaniel at, john at