Boost logo

Boost :

Subject: Re: [boost] bootstrap.bat broken for MinGW since 1.55
From: Eric Niebler (eniebler_at_[hidden])
Date: 2013-12-06 19:43:21

On 12/4/2013 11:45 AM, Eric Niebler wrote:
> On 12/03/2013 11:49 PM, Vladimir Prus wrote:
>> On 03.12.2013 18:37, niXman wrote:
>>>> I have tried with the source archive downloaded from Sourceforge, and
>>>> with
>>>> the master branch from Github, both times I get the same error. It works
>>>> fine with Boost 1.54.
>>>> Does anyone know what change could have caused this?
>>> Before the release of boost-1.55, I warned the developers about that.
>>> But they preferred to ignore me instead of fix it.
>> I'm am sorry that you feel like you've being ignored, but nobody in the
>> world likes to hack .bat files. Also, this
>> is partially a known problem, see:
>> Patches are appreciated!
> I have this partially implemented over here. I hope to finish it up
> later today.

I submitted a pull request that hopefully addresses this issue:

With this patch, you should be able to do:
> bootstrap.bat --with-toolset=mingw

... and it should do the right thing. It would be great if someone could
try it out.

Eric Niebler

Boost list run by bdawes at, gregod at, cpdaniel at, john at