Subject: Re: [boost] [git] Submodule's readme and logo
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2013-12-13 08:48:16
On Friday 13 December 2013 14:23:58 Adam Wulkiewicz wrote:
> Andrey Semashev wrote:
> > On Friday 13 December 2013 12:23:06 Adam Wulkiewicz wrote:
> >> Let me know what do you think about it. And don't hesitate to write
> >> about your ideas or propose changes.
> > I've taken a look at some of the logos. I don't quite like the specialized
> > Boost icons on the left. I'd prefer the common Boost icon to be used
> > without modifications, its white-blue color scheme looks more stylish to
> > me.
> Ok, and what do you think about those simple ones, without additional
Yes, these look better, but I still prefer the the official Boost icon more.
It's just simpler and more minimalistic, I guess.
> > Also, multi-word names of libraries use underscore. Although it's not
> > written anywhere to my knowledge, such names are typically spelled in one
> > word, camelcase, without underscores (e.g. Boost.SmartPtr). Here is the
> > discussion policy:
> > http://www.boost.org/community/policy.html#lib_names
> > This may not look very well on the logos though. So it's probably best to
> > stick with the official Boost logo without library names or no logo at
> > all.
> Yes, the naming scheme worked well with the Geometry and later I just
> followed it. I tested some other schemes and they look ok:
I don't know, neither one is particularly appealing. The last two versions are
the better ones, I think. The fourth, probably, is the preferred one.
Note also that there were alternative logos for the proposed libraries. I
can't find them now, but there's some version in my old docs:
I don't have the svg, sorry. I suppose, all the logos should be in the same
style, more or less.