Subject: Re: [boost] RFC: edit_distance / edit_alignment library
From: Bjorn Reese (breese_at_[hidden])
Date: 2013-12-15 07:58:30
On 12/14/2013 03:54 AM, Erik Erlandson wrote:
> I've been considering possible alternate names for the functions:
> edit_distance / edit_alignment
> or: edit_cost / edit_path
> or: edit_cost / edit_script
I suggest that you rename the boost::algorithm::sequence_alignment
namespace to boost::algorithm::edit. Then we can drop the "edit_"
prefix on the function names, giving boost:algorithm::edit::distance
and likewise for alignment.
The edit::distance is reminiscient of std::distance, so I think that
name should be retained. I have no strong opinion about edit::alignment.
Research papers use "edit alignment" but I find "edit path" slightly
Talking about naming, it may be a good idea avoid abbreviations for
some of the names. So "allow_sub" could become "allow_substitution"
(or just "substitution".)
Likewise, the cost function object has names like cost_ins and cost_del,
but as these are already located inside the cost function object, they
could be renamed to insertion and deletion (or erasure to match the STL
namining a bit better.)