Boost logo

Boost :

Subject: Re: [boost] Getting Started Testing with Linux virtual machine on Windows host
From: Bjørn Roald (bjorn_at_[hidden])
Date: 2013-12-19 01:37:40

On 12/19/2013 02:13 AM, Jonathan Wakely wrote:
> On 18 December 2013 22:22, Bjørn Roald wrote:
>> On 12/18/2013 10:01 PM, Jonathan Wakely wrote:
>>> On 17 December 2013 14:33, Beman Dawes wrote:
>>>> Seems a bit simpler to recommend "sudo mv b2 /usr/bin", although I don't
>>>> feel strongly about that.
>>> If your docs are specific to Ubuntu then it doesn't really matter, but
>>> not all distros support "sudo make me a sandwich" out of the box. On
>>> my Fedora systems I would get this:
>>> $ sudo mv b2 /usr/bin
>>> [sudo] password for redi:
>>> Sorry, user redi is not allowed to execute '/bin/mv b2 /usr/bin' as
>>> root on moria.localdomain.
>> Are you sure you would have this problem if you run Fedora in a virtual
>> machine you created,
> I haven't tried, but are you suggesting the default sudoers file is
> different if Fedora is installed in a VM? How does the OS know it's
> running as a VM guest?

No, I am not suggesting that. You could add


to /etc/sudoers then to make the procedure work, or simply use su
instead to log in as root before the install step.

>> You would have full root access, wouldn't you?
> No, not as a non-root user you create. Not by default anyway.

OK, I was in the impression you tried in on a machine where you did not
have root access as in not having the root password in your case.

> I think you can make "sudo make me a sandwich" work by creating the
> user as an Administrator during the Fedora installation process, which
> causes the user to be added to the 'wheel' group.

In that case you should be able to add the user to the "wheel" group at
any time to make the sudo based procedure work. But that is likely to
be specific for that distribution.


Boost list run by bdawes at, gregod at, cpdaniel at, john at