Boost logo

Boost :

Subject: Re: [boost] [git][predef] Pull fails
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2014-01-26 12:19:42

On Sun, Jan 26, 2014 at 8:23 PM, Andrey Semashev
<andrey.semashev_at_[hidden]> wrote:
> Hi,
> I checked out Boost on my Windows machine quite some time ago and
> today I tried to update it. I did:
> git submodule foreach git checkout develop
> git submodule foreach git pull
> The last command failed on Boost.Predef (log attached). I did not
> change it and I don't understand why there is conflict. I tried 'git
> reset --hard' and pull again, but it fails again the same way.
> How can I fix it?

And I have similar problems with Boost.Build. When I do 'git submodule
foreach git checkout develop' it checks out something outdated, with
v2 directory at the top level, saying that it has diverged from
origin/develop. Doing 'git pull', as it suggests, only brings a bunch
of conflicts and merges, and a half-merged tree in tools/build.

I can do 'git submodule update' and it does bring tools/build into
some decent state, without v2 on top, but checking out develop breaks
it again the same way. How am I supposed to work with develop?

PS: I'm really running out of polite words now towards git. This pile
of... bytes have given me nothing but trouble so far. I'm spending 1.5
hours now trying just to update the damn local copy, and every update
command runs for ages, because apparently it authenticates for every
submodule every time. Who in good will would use this... tool? <sigh>
I was probably born on another planet.

Boost list run by bdawes at, gregod at, cpdaniel at, john at