Subject: Re: [boost] [move] [range] move algorithm (was: interest: the pass-by-value...)
From: Krzysztof Czainski (1czajnik_at_[hidden])
Date: 2014-02-16 04:33:07
2014-02-15 23:17 GMT+01:00 Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>:
> Krzysztof Czainski wrote:
>> 2014-02-15 1:05 GMT+01:00 Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>:
> Hmm, how about:
>> boost::copy( range | movable, out_it );
> Yes, of course this should also be possible. There is already
> boost::move_iterator in Boost.Move. To be consistent with the standard we
> should probably also have boost::move() algorithm and a range adaptor. But
> the naming scheme for Range adaptors is different, the past tense should be
> used, right? Hence "moved".
The name 'moved' would misleadingly suggest that something already moved.
But then, so does 'move'.