Subject: Re: [boost] [range] Proposal: addition of front(), back(), at(), operator
From: Adam Wulkiewicz (adam.wulkiewicz_at_[hidden])
Date: 2014-03-25 12:22:49
Krzysztof Czainski wrote:
> 2014-03-23 20:59 GMT+01:00 Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>:
>> be intuitive. So the following should also be provided:
>> 4. sub(), subscript(), el(), element(), at_index(), at_(), index(),
>> indexed(), access(), operator, ...?
> +1 for subscript(rng,n).
> -1; for operator, I'd definitely prefer a named function call.
> The name 'at' would be a perfect name, if it only didn't have the throwing
> behavior in the Standard Library.
the last might also be related to the word 'index'.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk