Boost logo

Boost :

Subject: Re: [boost] [Boost-users] [typeindex v3.0] Peer review begins Mon 21st ends Wed 30th
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2014-04-23 12:26:54

> -----Original Message-----
> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of Nat Goodspeed
> Sent: 23 April 2014 16:16
> To: boost_at_[hidden]
> Subject: Re: [boost] [Boost-users] [typeindex v3.0] Peer review begins Mon
> ends Wed 30th
> [Not a review, but a response to one of Paul's comments]
> > On 23 Apr 2014 at 14:33, Paul A. Bristow wrote:
> >> Though I'm not enthusiastic about the name of namespace
> >> boost::typeind:: but I don't have any much better ideas. Perhaps someone
> has?
> > To clarify the issue to everyone else, TypeIndex is in a rather
> > unusual bind with regard to what namespace to use. Ideally I think
> > we'd all agree that boost::type_index would be best, but then one of
> > the issues raised last peer review was that there shouldn't be a
> > boost::type_index type as could conflict with std::type_index, and if
> > we hold that to be wise, then surely the same rationale applies for a
> > boost::type_index namespace as well.
> >
> > So we end up with boost::typeind, which I don't think makes anyone
> > happy, but it is safe.
> I don't suppose boost::typeindex would be an improvement? That name at least
> immediately suggests to the reader which library to look up.

I like this better too.

> Whichever name is selected, both the documentation and code comments at the
> namespace definition should explain, as above, why the author intentionally
> type_index.


Yours BikeSheddingly ;-)


Paul A. Bristow
Prizet Farmhouse
Kendal UK LA8 8AB
+44 01539 561830

Boost list run by bdawes at, gregod at, cpdaniel at, john at