Boost logo

Boost :

Subject: Re: [boost] Is there any interest in a library for actor programming?
From: Dominik Charousset (dominik.charousset_at_[hidden])
Date: 2014-05-22 13:56:58

>> I created the boost libraries and tried the configure again
>> and it worked. However, the subsequent make failed because compiler
>> could not find memcmp, as shown by the terminal session at the end of
>> this post. Note that I did do a `git diff` which showed the only'
>> difference was in the ./configure. Also, there were several
>> warnings.
>> Is there something I should do to get the make to work?
> [snip]
> I modified the configure arguments as shown in 1st attachment.
> Now, at the `make` step, it aborts at the same place, but
> with a message about incompatible args instead of not finding
> the memcmp function. The complete terminal session is in
> 2nd attachment.

Thank you for your patience. The function memcmp is defined in <cstring>, which was simply not included. I don’t know why I never got this error (I’ve tested on SuSE 13.1, Ubuntu 13.10, Fedora, Mac OS, MinGW @ Win7). Btw, you don’t have to pass both GCC and Clang to the configure script. I would recommend using the compiler you’ve used to build the Boost libraries to avoid running into ABI incompatibilities.

I have added the missing include in the master branch and fixed the mismatched-tags warnings as well. Hope that fixes your issues. Oh, and don’t be surprised that almost each file has changed if you’re running git pull: the license has been changed from LGPL to the Boost Software License.

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at