Subject: Re: [boost] Futures
From: Gavin Lambert (gavinl_at_[hidden])
Date: 2015-01-16 00:45:01
On 14/01/2015 03:13, Niall Douglas wrote:
> On 13 Jan 2015 at 9:01, Sylvester-Bradley, Gareth wrote:
>>> I do agree about BindLib being a poor name. It is actually onto its
>>> third choice of name now :( but to date, it's the least terrible of
>>> the reasonably descriptive library names I have thought of.
>> Yes, naming is the hardest problem. :-)
>> Not sure what you'll think of this, but how about Boost.Using?
>> Or Boost.NameAlias?
> Boost.Using ...
> Yes, I think I like that a lot. Thank you.
I'm not sure that's a good choice either, for all that it sounds cool.
Namespace boost::using would be confusing if it weren't illegal.
"Using Boost.Using" in documentation would be confusing. (Even more so
if "Boost" were omitted.)
I'm sure some people would think, on seeing it in an index or table of
contents somewhere, that it referred to general usage instructions for
Boost as a whole, rather than the name of a particular library.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk