Subject: Re: [boost] [Review] Boost.Endian mini-review
From: Beman Dawes (bdawes_at_[hidden])
Date: 2015-01-25 10:48:57
On Fri, Jan 23, 2015 at 6:25 PM, Olaf van der Spek <ml_at_[hidden]> wrote:
> Also got a question about the name endian_reverse: wouldn't
> reverse_endian make more sense?
I've gone around and around in circles between "reverse_endianness"
(most explicit, but too long), "reverse_endian" (which grates on me a
bit because every time I see it I waste time thinking it should be
spelled "reverse_endianness"), and "endian_reverse". I like
endian_reverse because it starts right out by alerting the reader as
to the context of the reversal. Since this function is used as a UDT
customization point, so gets defined in a user namespace for UDT
types, that seems important to me.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk