Subject: Re: [boost] [type_traits] Rewrite and dependency free version
From: Emil Dotchevski (emildotchevski_at_[hidden])
Date: 2015-02-02 15:30:41
On Mon, Feb 2, 2015 at 11:57 AM, Robert Ramey <ramey_at_[hidden]> wrote:
> this is the result of naming issues. the word array has been used for
> boost::array, std::array and the built-in C/C++ array. They all ended
> up in the same header so that one could find them when they were needed.
Ideally they should be separated, and boost::array's serialization should
go into a boost::array header.
As for serialization core dependencies, isn't it possible to define
serialization function template overloads for user-defined types without
including serialization library headers? E.g. aren't all function calls one
makes in operator<< overloads dependent on the archive template argument?
-- Emil Dotchevski Reverge Studios, Inc. http://www.revergestudios.com/reblog/index.php?n=ReCode
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk