Subject: Re: [boost] [Review] Boost.Endian mini-review
From: Rob Stewart (rob.stewart_at_[hidden])
Date: 2015-02-12 08:47:31
[I found this languishing in my drafts folder. Sorry it's late.]
"operators are +, -, ~, !, prefix and postfix -- and ++" has too many "and"s. Try, "operators are +, -, ~, !, plus both prefix and postfix -- and ++".
The binary arithmetic and relational operators lists really should have "and" before the final operator in each series.
Comments I made on buffer.html, like those on the warning and note after the typedef table apply to this page.
In, "An endian is an integer byte-holder", I presume that "endian" should be "endian_arithmetic". (If not, then s/endian_arithmetic/endian/ throughout the page. The same applies to the synopsis. The two are used variously.
The effects for the default constructor say nothing about the value. If it is uninitialized, a note to that effect would be helpful.
(Sent from my portable computation engine)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk