Subject: Re: [boost] [Hana] Informal review request
From: Louis Dionne (ldionne.2_at_[hidden])
Date: 2015-03-05 14:14:58
Louis Dionne <ldionne.2 <at> gmail.com> writes:
> Steven Watanabe <watanabesj <at> gmail.com> writes:
> > [...]
> > - Is there a reason for using length instead of size,
> > which would be more idiomatic in C++?
> Oversight caused by personal preference.
> I guess I should change that.
Hmm, on second thought, length applies to any Foldable, not
only to sequences. There might be a case where length is
meaningful but not size (or vice-versa)? What if I provided
both methods, one as an alias to the other?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk