Subject: Re: [boost] [next gen future-promise] What to call the monadic return type?
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2015-05-26 07:19:09
> -----Original Message-----
> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of Niall Douglas
> Sent: 26 May 2015 11:23
> To: boost_at_[hidden]
> Subject: Re: [boost] [next gen future-promise] What to call the monadic return type?
> On 26 May 2015 at 5:07, Rob Stewart wrote:
> > On May 25, 2015 7:09:57 PM EDT, Niall Douglas <s_sourceforge_at_[hidden]> wrote:
> > > On 25 May 2015 at 23:35, Vicente J. Botet Escriba wrote:
> > >
> > > Names suggested so far are maybe, result, holder, value.
> > I'm still trying to understand use cases to help guide naming.
> Exactly why I asked for people to bikeshed here on the naming. I am also unsure.
<bikeshedding_mode = on>
--- Paul A. Bristow Prizet Farmhouse Kendal UK LA8 8AB +44 (0) 1539 561830
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk