Boost logo

Boost :

Subject: Re: [boost] [next gen future-promise] What to call the monadicreturntype?
From: Peter Dimov (lists_at_[hidden])
Date: 2015-05-26 11:04:39

Niall Douglas wrote:

> Get some experience programming in Rust and come back to me.

This is a very generous offer, which I'm afraid I have to decline at

> I think you'll realise that monadic programming is going to become huge in
> C++ 11/14 in the near future in those use case scenarios where it is far
> better than all other idioms.

With that qualification this statement is trivial, isn't it? My point was
that there do exist other scenarios, where monadic programming of this
particular expected<> variety is not at all far better than other idioms.

Either way, consider my message a naming suggestion for the bikeshedding
session. My naming suggestion is that your type is properly called

    future<expected<T, error_code>>.

This name in no way prevents you from going all monadic on our posteriors.

Boost list run by bdawes at, gregod at, cpdaniel at, john at