Subject: Re: [boost] Boost.DLL formal review is ongoing
From: Antony Polukhin (antoshkka_at_[hidden])
Date: 2015-07-13 16:24:33
2015-07-13 21:47 GMT+03:00 Rob Stewart <rob.stewart_at_[hidden]>:
> 4. A generic term I use for DLLs, shared objects, etc. is "dynamic
> library." I suggest that the documentation define that term once, up front,
> and then use it everywhere else rather than repeating the "DLL, shared
> object (DSO), etc." phrase. I'd also encourage using that name for the
> library itself (Boost.DynamicLibrary) and for the shared_object class.
I was trying to keep namings platform neutral: "dynamic library" is too
Windows specific, "shared object" is too POSIX specific... Let it bee DLL
for library abbreviation and "shared object" mostly in docs and source
codes. However it does not seem so right and platform neutral right now,
especially when dll::shared_object and dll::library_info are nearby in
code. It may be profitable to rename dll::library_info into
> I expect to be able to complete a review sometime next week, if the
review manager is inclined to wait for it.
Anyway, I'm interested in your opinion, so please send the review when
you'll be ready.
Any library related comments from any reviewer are welcomed even after the
-- Best regards, Antony Polukhin
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk