Boost logo

Boost :

Subject: [boost] Build Error VS14 + Intel 15.0 (Update 4, the latest)
From: degski (degski_at_[hidden])
Date: 2015-08-10 01:13:20

I have encountered the following error when building boost 1.58 (and

C:/boost_1_58_0/tools/build/src/tools\intel-win.jam:194: in
configure-really from module intel-win
error: msvc 14 not supported for intel toolset version 15.0

I'm using the following line to build boost:

bjam -a -d+2 --toolset=intel-15.0-vc14 "-sINTEL_PATH=C:\Program Files
(x86)\Intel\Composer XE 2015\bin\intel64" cxxflags="/O2
/Quse-intel-optimized-headers /Qstd=c++14 /Qipo /Zc:forScope /Oi /MT /EHsc
/Qparallel" "-sINTEL_BASE_MSVC_TOOLSET=vc-14_0" "-sINTEL_VERSION=15"
"-sZLIB_SOURCE=%HOME%\zlib-1.2.8" "-sBZIP2_SOURCE=%HOME%\bzip2-1.0.6"
variant=release instruction-set=nehalem threading=multi link=static
runtime-link=static --stagedir=stage64_static address-model=64
architecture=x86 --without-python --without-mpi --disable-filesystem2 stage
> icc_log_stage.log

The above worked fine with VS11 and Intel 15.0.

The combo (VS14/ICC15) is obviously supported by (MS/Intel), and works fine
in the IDE (Community Edition).

I confirm the problem with bootstrap.bat, this has been around for a long
time, and always had to build the 32bit version first. I ran into it as I
have decided to stop building 32-bit. The obvious work-around is to build
bjam seperately, not a killer for me, but might be for some.

The main issue I report, is though and it would be a shame if the 1.59
release would not allow for that combo, as finally MS have released a free,
non-crippled, release of their IDE with (finally, in 2015) full support for

I'm happy to test some things out if necessary, I'm not capable of
adressing the issue though...

Boost list run by bdawes at, gregod at, cpdaniel at, john at