Boost logo

Boost :

Subject: Re: [boost] [afio] running tests
From: Niall Douglas (s_sourceforge_at_[hidden])
Date: 2015-08-30 09:34:17

On 29 Aug 2015 at 23:13, Michael Caisse wrote:

> I'm trying to run the tests. I'm certain I am just doing something
> really silly... input is welcome!
> I have dropped the AFIO repo into a libs/afio directory for the super
> project. I ran ./b2 headers which linked in the boost/afio bits. I then
> go to libs/afio/test and execute "b2 release" which unfortunately
> results in:
> find: libs/afio: No such file or directory
> Performing configuration checks
> ...
> This is the same way I run other library tests and those are working as
> normal. Is there some other setup step that I'm forgetting?

Almost certainly you need to ask Boost.Build for C++ 11 else it
ignores C++ 11 Boost libraries. See

Note that as AFIO is standalone capable, simply entering its
directory and typing:


should "just work" if you have a Filesystem TS on your system. If
not, it'll auto-configure including Boost.Filesystem.


ned Productions Limited Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at