Boost logo

Boost :

Subject: Re: [boost] QVM Review
From: Rainer Deyke (rainerd_at_[hidden])
Date: 2015-12-16 16:38:39

On 16.12.2015 22:21, Emil Dotchevski wrote:

> The swizzling syntax must be terse or else it's useless. If you've written
> shader code you'll know utterly inadequate it is to require a syntax like
> swizzle<1,0,3,2>(vec) instead of (vec,YXWZ). At any rate, swizzling is
> defined in a separate header, don't include it if you don't want it.

YXWZ(vec) is not only much more readable than (vec,YXWZ), it's also one
character shorter.

Rainer Deyke (rainerd_at_[hidden])

Boost list run by bdawes at, gregod at, cpdaniel at, john at