Subject: Re: [boost] [review][qvm] QVM formal review report
From: Emil Dotchevski (emildotchevski_at_[hidden])
Date: 2016-01-04 21:37:45
On Sun, Jan 3, 2016 at 10:11 AM, Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>
> - The identifiers should be made more verbose. This is true both for
> function names as well as identifers containing "q"/"v"/"m" parts. The
> former should be replaced with full words, e.g. "transp" -> "transpose".
> The latter should be replaced at least with "qua"/"quat"/"vec"/"mat"
> respectively, so e.g. "v_traits" -> "vector_traits"/"vec_traits", "col_m"
> -> "col_mat", etc.
Does this include header file names?
If you look in the boost/qvm directory, you'll see that currently the q, v
and m prefix naming convention is followed for file names as well (q and v
prefixes by analogy):
m.hpp: any size matrix operations
m2.hpp: 2D matrix operations
m3.hpp: 3D matrix operations
m4.hpp: 4D matrix operations
m_access.hpp: matrix element access functions
m_traits.hpp: m_traits template definition
m_traits_array.hpp: m_traits specialization for C arrays
qv.hpp: operations between quaternions and vectors
vm.hpp: operations between vectors and matrices
map_mm.hpp: matrix-to-matrix view proxies
map_mv.hpp: matrix-to-vector view proxies
map_vm.hpp: vector-to-matrix view proxies
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk