Subject: Re: [boost] Alternative names to Boost.Fit
From: Robert Ramey (ramey_at_[hidden])
Date: 2016-03-05 13:00:15
On 3/5/16 8:25 AM, Paul Fultz II wrote:
>> Shortening the name creates confusion, makes code less readable. Since
>> most of the library is defined inside the namespace, it doesn't really
>> add any typing. In those cases where the typing does get long, one can
>> at a (local) alias.
> However, you can't namespace alias a macro though.
Hmmm - you can't? Cant you just use
#define MY_SHORTNAME RIDICUOUSLY_LONG_NAME
MYSHORTNAME(X) in place of RIDICUOUSLY_LONG_NAME(X)
I seem to recall this working. Even if you can't, I'd say the benefit
of an abbreviation isn't worth the confusion it causes.