Boost logo

Boost :

Subject: Re: [boost] [Fit] formal review - should we propose some parts to Boost.Config/Boost.Core
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2016-03-06 03:59:24

On 2016-03-06 05:21, Vicente J. Botet Escriba wrote:
> Others could be considered also as function.hpp, lambda.hpp and
> lift.hpp, as the macros are there to workaround some missing language
> features, but those are much more specialized (Boost.Core?)

I don't think Boost.Core is the right place for them as this library is
for small generally useful components used by many libraries. The
components you pointed out seem too specialized to me, and Boost.Fit
looks like the right place for them.

Boost list run by bdawes at, gregod at, cpdaniel at, john at