Subject: Re: [boost] [Fit] formal review ends 20th March.
From: Bjorn Reese (breese_at_[hidden])
Date: 2016-03-22 04:51:53
On 03/21/2016 07:04 PM, Paul Fultz II wrote:
> However, with lambdas it is the opposite. Lambdas default to const and then
> explicit mutable keyword is needed for a mutable function object.
The const-by-default lambdas are the black swans of C++.
The fit documentation should at least provide a design rationale for
its const-by-default decision which is addressed at those who are
unfamiliar with the virtues of immutability.
Another concern with fit::mutable_ is its name. As you have already gone
down the type-traits naming path with fit::decay, it may be an idea to
rename fit::mutable_ to fit::remove_const.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk