Subject: [boost] Naming convention of iterated binary operation
From: Jeremy Murphy (jeremy.william.murphy_at_[hidden])
Date: 2016-05-01 23:25:39
Dear list entities,
is there such a convention or precedent for naming an iterated binary
For example, Boost.Functional/Hash has an iterated hash() called
hash_range(). I don't mind the "_range" suffix but I prefer the "iterated_"
prefix based on the mathematical definition:
The case in point is gcd() in Boost.Math: we want to provide an iterated
gcd but we can't quite decide how to name it. I like the "iterated_" prefix
but I would rather go with whatever might be the convention.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk