Boost logo

Boost :

Subject: Re: [boost] Formal Review Request: mp11
From: Bjorn Reese (breese_at_[hidden])
Date: 2017-03-18 14:14:55

On 03/18/2017 02:55 PM, Peter Dimov via Boost wrote:

> mp_transform is variadic, it works on more than one list.

Ok. How about having two versions? One that takes a single typelist
(at the beginning) and one that takes an arbitrary number. The latter
should probably be named differently to indicate that its arguments
deviate from the rest of the algorithms (e.g mp_multi_transform.)

> mp_transform<std::pair, mp_list<int, float>, mp_list<char, double>>
> ->
> mp_list<std::pair<int, char>, std::pair<float, double>>

Oh, a zip. That looks useful. You should add that example to the

Boost list run by bdawes at, gregod at, cpdaniel at, john at