Boost logo

Boost :

Subject: Re: [boost] [review] Review of PolyCollection starts today (May 3rd)
From: Vinnie Falco (vinnie.falco_at_[hidden])
Date: 2017-05-10 21:01:11

On Tue, May 2, 2017 at 4:46 PM, Ion Gaztañaga via Boost
<boost_at_[hidden]> wrote:
> The library can be found here:
> ...

The documentation looks beautiful and I was excited by the positive
review comments so I thought I would have a look. Unfortunately, I ran
into considerable difficulty trying to actually build the example and
poke around. There are no instructions on how to build that I could
find in the repository or the documentation.

First I tried cloning the repository and building:

$ cd ~/src
$ git clone git_at_[hidden]:joaquintides/poly_collection
$ cd poly_collection/example
$ b2

Produced this output:
in load-parent from module project
error: Could not find parent for project at '.'
error: Did not find Jamfile.jam or Jamroot.jam in any parent directory.
in initialize from module project
in load-jamfile from module project
in load from module project
in project.find from module project
in load from module build-system
in import from module modules
in boost-build from module
C:\Users\vinnie\lib\boost_1_64_0\boost-build.jam:17: in module scope from module

Now I remember some jibber jabber about putting projects in the live
Boost directory (a practice which I am not fond of). In the interest
of moving forward I tried it.

$ cd ~/lib/boost_1_64_0
$ git clone git_at_[hidden]:joaquintides/poly_collection
$ cd poly_collection/example
$ b2

It got a little farther this time but still does not build:

Performing configuration checks

    - 32-bit : yes (cached)
    - arm : no (cached)
    - mips1 : no (cached)
    - power : no (cached)
    - sparc : no (cached)
    - x86 : yes (cached)
...found 1033 targets...
...updating 23 targets...
compile-c-c++ ..\..\bin.v2\poly_collection\example\msvc-14.1\debug\threading-multi\algorithms.obj
algorithms.cpp(12): fatal error C1083: Cannot open include file:
'boost/poly_collection/algorithm.hpp': No such file or directory

Did I mention I am using Microsoft Visual Studio on Windows?

Full disclosure, I have had this problem twice before when trying to
review libraries. In the past I have simply given up. But I want to
contribute something back since my own library will be reviewed soon.


Boost list run by bdawes at, gregod at, cpdaniel at, john at