Subject: Re: [boost] [review][mp11] Formal review of Mp11
From: Bjorn Reese (breese_at_[hidden])
Date: 2017-07-22 09:23:06
On 07/17/2017 01:06 PM, Joaquin M LÃ³pez MuÃ±oz via Boost wrote:
> My personal opinion is that 1 should be given priority, followed by 2
> and, at a distance, 3.
> It is a submission for Boost we're dealing here with. In that light, mp_
> sounds like noise
> to me (also for 3, but this is not a subject for this review).
The main problem is that some names would collide with C++ keywords. A
quick scan of the documentation reveal these possible conflicts: bool,
true, false, int, if, and void.
I am wondering if there is an alternative solution to the mp_ prefix
and the MPL-style _ suffix.
For instance, type-traits have faced the same problem and selected
synonyms, e.g. std::conditional instead of if, or longer names, e.g.
true_type and false_type.
Would that be a feasible approach?