Subject: Re: [boost] [contract] ready to release
From: Lorenzo Caminiti (lorcaminiti_at_[hidden])
Date: 2018-01-10 19:45:26
On Tue, Jan 9, 2018 at 7:29 AM, Lorenzo Caminiti <lorcaminiti_at_[hidden]> wrote:
> Boost.Contract in master is ready to be added to the next Boost
> release (regression tests pass, docs are updated, etc.).
I turns out the Boost inspect program reports the following:
(line 102) Apple macro clash: check
(line 29) Apple macro clash: check
Are these a real issues? Boost.Contract uses 'check' as:
boost::contract::check c = boost::contract::function().precondition(...);
I could of course renamed that to 'check_' but it looks ugly...
Will a class named check in boost::contract namespace really clash
with Apple defined names? Or this only an issue for ancient Apple
compilers and I no longer have to worry about it?