Boost logo

Boost :

Subject: Re: [boost] [build] msvc-14 linker step failing?
From: Robert (r.firl_at_[hidden])
Date: 2018-02-05 15:43:26

On 2/5/2018 8:11 AM, degski via Boost wrote:
> On 5 February 2018 at 06:07, John Maddock via Boost <boost_at_[hidden]>
> wrote:
>> Looking into this further, some of the start menu command prompt scripts
>>> work (as in support mt) and some don't.... looks like I need to try
>>> reinstalling.
>> Confirmed that that fixed it: looks like my msvc-14.0 install got messed
>> up by msvc-15.x at some point :(
> For a while, I ran vs2015 and vs2017 alongside each other (officially
> supported setup) and it became messy. In the end I did like you, I ditched
> vs2015 and reinstalled vs2017, no issues!

FWIW, I have to use both 2017 and 2015. Consequently, I always manually
open a dedicated Visual Studio command prompt for x86, x64, VS2015,
VS2017 as appropriate. Plus with VS2017, many of the directory paths to
reach the various support files and executables are too long. I have a
permanent link with mklink that is
C:\v7 = "C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise"


> degski
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at