Subject: Re: [boost] Formal Review of Proposed Boost.Histogram Library Starts TODAY
From: Mateusz Loskot (mateusz_at_[hidden])
Date: 2018-09-24 16:33:14
On Mon, 24 Sep 2018 at 16:19, Hans Dembinski via Boost
> > On 24. Sep 2018, at 13:24, <a.hagen-zanker_at_[hidden]> <a.hagen-zanker_at_[hidden]> wrote:
> >> shape() is more concise than `size() + has_overflow() + has_underflow()`, and the doxy string explains what it returns. If you have a better name, let me know
> > I suppose total_size() or full_size() is more intuitive, but of course not so elegant to have both size() and total_size().
> total_size() is less ambiguous than shape(), so I am half-convinced. I would like to have one-word method instead of two-word method.
I'm not great in naming things, but perhaps:
shape -> capacity() // as total size including optionally enabled space
uoflow() -> tails()
-- Mateusz Loskot, http://mateusz.loskot.net