Boost logo

Boost :

Subject: Re: [boost] Formal Review of Proposed Boost.Histogram Library Starts TODAY
From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2018-09-25 20:18:19

Hi Gavin,

> On 25. Sep 2018, at 02:44, Gavin Lambert via Boost <boost_at_[hidden]> wrote:
> How about "extent()"?
> It still conveys a size-like noun, and has association with "physical size" in a filesystem context, but without the connotations of "capacity()" in a container context.
> […]
> Agreed that consistency is important. I don't like "tails"; I'm neutral on "uoflow" (perhaps a shade against due to difficulty to type).
> I believe someone else suggested "excess" or "extra". Perhaps that might be more suitable?

Thank you for the input!

I like "extent()" as a replacement for "shape()". That's my favourite so far.

I slightly prefer "extra" over "excess". On the one hand, "excess" sounds more specific than "extra". On the other hand, "excess" sounds like we could use this method to access the value of the overflow/underflow bins, but the method merely queries whether overflow/underflow bins exist. Maybe that's just because of the phonetic similarity between "excess" and "access".

"extra" is nice, because it is about extra bins.

Here is another alternative for "uoflow()". The method is simply called options() and options_type is an enum class that holds or-able bit-masks

enum class options_type {
  underflow_bin = 1,
  overflow_bin = 2
  // more options could be added in the future

This is straight-forward and future-safe.


Boost list run by bdawes at, gregod at, cpdaniel at, john at