Boost logo

Boost :

From: Andrzej Krzemienski (akrzemi1_at_[hidden])
Date: 2019-11-28 08:55:38

Hi Everyone,
First, I would like to thank Vinnie and Krystian for writing and sharing
the library.

While this is not a review, I would like to share a thought about the
choice of name. Given that we have static_vector, which seems to be doing a
similar thing, why was this library called fixed_string rather than
static_string? I note that name fixed_string has some potential to mislead
the users as it might imply that it is the size that is fixed (like "a
string that always stores 2-letter country codes"). I am not saying that
the name choice is wrong. I would just want to see the rationale.


Boost list run by bdawes at, gregod at, cpdaniel at, john at