Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2021-06-08 15:20:27

Andrey Semashev wrote:
> > Getting back to Boost.Test, I've duplicated the targets with an included_
> > prefix:
> >
> >
> Not to start a bikeshedding argument, but maybe a more generic naming
> scheme would be preferable?

Since the normal unit_test_framework is used with

#include <boost/test/unit_test.hpp>

and the "included" one is used with

#include <boost/test/included/unit_test.hpp>

it seemed natural to call the target Boost::included_unit_test_framework
in the second case. (Similarly with the execution monitors.)

Boost list run by bdawes at, gregod at, cpdaniel at, john at