Boost logo

Boost :

From: Vinnie Falco (vinnie.falco_at_[hidden])
Date: 2021-10-12 23:36:59


On Tue, Oct 12, 2021 at 4:26 PM Peter Dimov via Boost
<boost_at_[hidden]> wrote:
> template<class T> void hash_combine( size_t& seed, T const& v )

In principle it sounds like an improvement, but what about the paper
"Types Don't Know #?"
(http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2014/n3980.html)

The paper shows empirical evidence that hash_combine has poor
collision properties when composing hash functions.

> I also think that Boost.ContainerHash should just be renamed to
> Boost.Hash as that's what it is - it defines boost::hash.
>
> So, I am thinking of taking over ContainerHash and doing all that,
> if there are no objections.

What happens with hash_append from the paper?

Thanks


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk