> From: Peter Dimov [mailto:pdimov@mmltd.net]
>
> 1)
>
> #include <boost/lexical_cast.hpp>
> #include <string>
> #include <iostream>
>
> int main()
> {
>     std::cout << boost::lexical_cast<std::string>("this is a test");
> }
>
> 2) to_string() is the established, novice-friendly name for
> this idiom; even
> with a working lexical_cast, I'd prefer to_string when I want
> to_string
> behavior since it leaves less room for errors.
>

I agree. Is it to small to deserve its own header (boost/to_string)?

Bjorn