Boost logo

Ublas :

From: Andreas Klöckner (kloeckner_at_[hidden])
Date: 2005-03-02 11:45:42

Hi all,

Since backwards compatibility is being broken anyway by the merging of
the ublas_pure branch, I would like to ask whether the
coordinate_matrix<>::insert_element operation could be renamed to
something different, to fix the confusing inconsistency with
matrix<>::insert_element. (The former is equivalent to A(i,j) += b,
while the latter is A(i,j) = b, if I'm not mistaken.)

My current best suggestion for a new name is "add_insert_element", which
could also easily be added on most other matrix types. Proper
coordinate_matrix<>::insert_element semantics could be achieved in
linear time w.r.t. the number of elements present.

I would volunteer to perform this change if there is any interest in it.


Dipl.-Math. techn. Andreas Klöckner   | FON +49 721 608-7982
Institut für Angewandte Mathematik II | FAX +49 721 608-6679
Universität Karlsruhe                 | EMAIL kloeckner_at_[hidden]
Englerstraße 2                        |
76128 Karlsruhe                       | RAUM 022
Germany                               | Kollegiengebäude Mathematik