Boost logo

Ublas :

From: Angus Leeming (angus.leeming_at_[hidden])
Date: 2005-11-04 06:38:52

Michael Stevens wrote:

> On Wednesday, 2. November 2005 08:58, Christophe Prud'homme wrote:
>> Michael,
>> | I was just going to commit and had second thoughts! To me it
>> | seems including <boost/concept_check.hpp> is a bit heavyweight to
>> | just get the "boost::ignore_unused_warnings" function. Until such
>> | appears in boost utilities maybe it would be better to simply
>> | duplicate the code in one of the uBLAS headers.
>> |
>> | What do you think?
>> Just a little bit longer than my previous answer:
>> that is certainly better. If you tell me where to put
>> ublas::ignore_unused_warnings() I could produce a new patch for
>> you.
> That is great. I would place the code in "detail/defininitions.hpp"
> before or after the code for nonassignable. Might be good to put it
> in a sub-namespace 'detail' as it will only be for internal use.

Michael, Christophe,

I attach my version of the patch. It suppresses all warning messages
in my own code, so I'm happy :)